FAQ

From ProAudioOverlay

(Difference between revisions)
Jump to: navigation, search
(OigsolYBIz)
Line 1: Line 1:
-
=Overlay specific=
+
sOESWg  <a href="http://hnofuwilwkjk.com/">hnofuwilwkjk</a>, [url=http://hosrkntwjzmh.com/]hosrkntwjzmh[/url], [link=http://dowpzvhlpgqw.com/]dowpzvhlpgqw[/link], http://jiaxonzrglgg.com/
-
==I want to contribute! What do I have to do?==
+
-
Evermind wrote [[New Developer/Maintainer guide|a nice guide]] on how to work with and contribute to the overlay.
+
-
Please read the guide first, if you still have questions feel free to ask on the [[Mailing List]]
+
-
 
+
-
==svn/cvs/whatever-ebuilds==
+
-
we use standard gentoo ebuild scheme for snapshot ebuilds. So there will be no longer ebuilds named: '''foo-cvs-1.ebuild''' Instead they are named '''foo-9999.ebuild'''<br>
+
-
e.g. to compile the latest rosegarden svn checkout you now have to do the following:
+
-
echo "media-sound/rosegarden **" >> /etc/portage/package.keywords
+
-
emerge rosegarden
+
-
'''KEYWORDS="-* is no longer valid'''<br>
+
-
to upgrade your /etc/portage/package.keyword you could run 'convert_live_keywords' inside the overlay root
+
-
./convert_live_keywords -cp
+
-
If you get messages about *-cvs/svn "Blocked Packages"  remove the blocked one and try again<p>
+
-
==ardour ebuilds==
+
-
We have various ardour ebuilds:
+
-
*ardour-0.99.x and ardour-99991 (svn: bugfixes for 0.99x only) refer to '''ardour-0.99xx'''
+
-
*ardour-2.0.x and ardour-2.0.99992 (svn: bugfixes for 2.0.x only) refer to '''ardour-2.0.x'''
+
-
*ardour-99992 fetches always the latest svn
+
-
*both (ardour-0.99.x and ardour-2.x.x) could be installed parallel
+
-
 
+
-
 
+
-
'''Hint:''' with the USE-flag: sys-libs ardour uses the system libs instead the one supplied with ardour.<br>
+
-
But there is '''no''' upstream ardour developer support
+
-
$ euses sys-libs
+
-
media-sound/ardour:sys-libs - use system libs instead of provided. No upstream support!!!
+
-
 
+
-
so don't blame anyone if something is wrong when using this USE-flag<br>
+
-
This USE-flag is just available for the ardour-2.0.x ebuilds
+
-
 
+
-
=Technical Questions=
+
-
==RT Kernel, realtime-lsm ...wtf?==
+
-
just to clear that out again.. people tend to confuse the realtime-lsm kernel module with the realtime-preemption kernel patch
+
-
 
+
-
'''realtime-lsm''' is nothing else but a linux security module (LSM) which makes it possible to grant users access to the realtime capabilities of the Linux kernel. It works on any kernel. This is going to be replaced by PAM's pam_limits.so which uses the kernel's RLIMITS feature to allow users access to the realtime capabilities in a more secure way than realtime-lsm does.
+
-
 
+
-
'''realtime-preemption''' is a feature provided by a kernel patch from Ingo Molnar. It makes the kernel fully preemtible which reduces latencies, especially on audio tasks. A kernel patched with the realtime-preemption patch is called RT-kernel. This has to do with CPU scheduling, but nothing with user permissions.
+
-
 
+
-
 
+
-
==Intel HDA and lots of xruns?==
+
-
The Intel HDA chips tend to suffer some problems when used with jackd.
+
-
 
+
-
So if you get tons of xruns with your HDA chip, try setting the Periods/Buffer value to 3 in qjackctl, or commandline:
+
-
jackd -dalsa -n3
+
-
If that still does not help, try turning off realtime.
+

Revision as of 14:14, 7 June 2010

sOESWg <a href="http://hnofuwilwkjk.com/">hnofuwilwkjk</a>, [url=http://hosrkntwjzmh.com/]hosrkntwjzmh[/url], [link=http://dowpzvhlpgqw.com/]dowpzvhlpgqw[/link], http://jiaxonzrglgg.com/

Personal tools